本站已经迁移到Linode服务器

March 08 , 2016

阿里云的服务器实在是太贵了,而且带宽太小,所以决定迁移到Linode的日本服务器

虽然延迟会稍微高点,但是价格能便宜一半

自己也能搭个SS,PPTP之类的玩玩(不就是舰娘嘛~,看看AKB48嘛~)

然后尝试在新的服务器使用最新的php7

去年年底就出了,一直在观望,怕有什么大的bug,所以一直没用

php7扩展问题

关于php7的安装,我还是一如既往的喜欢使用自己手动编译的方式安装

有几个重要的点需要说下,php7本身在安装的时候没有什么问题,就是一些扩展方面不能使用以前的扩展了。

比如memcache我使用旧版本就无法安装,然后我换成使用memcached,而且必须使用git上面专门针对php7的分支进行安装

github地址: https://github.com/php-memcached-dev/php-memcached

注意不要选择master分支,要选择php7分支进行下载

关于安装方法还是一样,phpize,然后configure,然后make && make install

我贴个网上找的教程:http://www.aiuxian.com/article/p-3220065.html

那么除了memcached意外还有ssh2这个扩展也是一样,这里就不具体说了,跟上面也是一样去git上找对应的扩展

附上教程,国外的链接,可能需要翻才能打开

https://medium.com/php-7-tutorial/solution-how-to-compile-php7-with-ssh2-f23de4e9c319#.gg6rmsgt7

其他

php7我也是刚刚开始使用,安装这块大家不懂的可以留言

那么新的一年也要加油

争取把自己挖的坑填完~

游客评论区

#1 匿名游客 2016-03-18 12:08:24 / 回复

从github上下载,不应该直接用pull下来的代码,应该用其的release,或者switch to tag。


#2 匿名游客 2016-08-03 14:41:03 / 回复

前排支持。


发表评论

(请不要填写空的评论)
提交评论 使用QQ登录